2022 『二次元足球妹子』 监控系统报警抓嫌犯 闽人工智能产业或迎爆发期-xn--2014-ye6f69knrrveo7phrjol5gx32b.fsjumeng.com

顶部左侧

MACD背离金叉副图指标 源码 通达信(图文)黄金

2022-09-25 18:39:42 阅读()
导读:MACD背离金叉副图指标 源码 通达信 DIFF:EMA(CLOSE,12)-EMA(CLOSE,27);DEA:EMA(DIFF,9);MACD:2*(DIFF-DEA), COLORSTICK,LINETHICK2;低位金叉:=CROSS(DIFF,DEA

MACD背离金叉副图指标 源码 通达信




DIFF:EMA(CLOSE,12)-EMA(CLOSE,27);
DEA:EMA(DIFF,9);
MACD:2*(DIFF-DEA), COLORSTICK,LINETHICK2;
低位金叉:=CROSS(DIFF,DEA) AND DIFF<-0.1;
DRAWICON(低位金叉,DEA*0.9,1) ;
JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));
二次金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;
DRAWICON(二次金叉,DEA*0.9,5) ;
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
底背离:=REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND
CROSS(DIFF,DEA);
底背:DRAWLINE(A1=0,DEA,底背离,DEA,0),COLORRED,LINETHICK4;
DRAWTEXT(底背离,-1,' 底背'),COLORRED;
DRAWICON(CROSS(DEA,DIFF),DIFF,2);
A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));
顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND
CROSS(DEA,DIFF);
顶背:DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORGREEN,LINETHICK4;
DRAWTEXT(顶背离,1,' 顶背'),COLORGREEN;
三全项:=(低位金叉 AND 二次金叉 AND 底背离);
STICKLINE(三全项,0,0.8,1,0),COLORYELLOW,LINETHICK2;
DRAWTEXT(低位金叉 AND 二次金叉 AND 底背离,1,'三全项'),COLORYELLOW;
MACD值:2*(DIFF-DEA),COLORSTICK,COLORRED;
VAR8:=SUM(MACD值,0);
VAR9:=IF(MAX(VAR8,REF(VAR8,2))<REF(VAR8,1) OR MIN(VAR8,REF(VAR8,2))>REF(VAR8,1),1,0);
VAR10:=BARSLAST(VAR9)+1;
VAR11:=VAR8-REF(VAR8,VAR10);
VAR12:=IF(MACD值>0,HHV(ABS(MACD值),VAR10),LLV(MACD值,VAR10));
VAR13:=MACD值/20;

红面积:SUM(MACD,BARSLAST(MACD<0))*(MACD>0),COLOR0000FF,NODRAW;
绿面积:SUM(MACD,BARSLAST(MACD>0))*(MACD<0),COLORFFFF00,NODRAW;
AA:=ROUND(REF(绿面积,1)*100);BB:=ROUND(REF(红面积,1)*100);
DRAWNUMBER(CROSS(0,MACD),HHV(REF(MACD,1),5)+0.03,ABS(BB)),COLORMAGENTA;
DRAWNUMBER(CROSS(MACD,0),LLV(REF(MACD,1),5)-0.03,ABS(AA)),COLORGREEN;
 


免责声明:本文系转载,版权归原作者所有;旨在传递信息,不代表本站的观点和立场。
唐人社在线av 在线手机av网站 av大帝免费 AV种子贴吧 xfplay电影Av网 影音先锋
小锅av转hdmi转换器 手机版av天堂 日韩av在线网站观看 亚洲黄色av 百度网盘吧 av资源
av线两用 亚洲成色av 岛国av无码影音先锋 波多野结衣无码AV全集种子迅雷 123av天堂
京香av种子迅雷下载 av亚洲天堂最新地址 亚洲人成电影网站免av费 午夜AV在线网址 影音先峰av好看